FIX FOR SLOW IE7 PHISHING FILTER

A few people have complained that Internet browsing was slow or erratic after installing Internet Explorer 7. I haven’t been able to find a pattern to explain that – no widespread reports of similar problems online, nothing other than scattered problems among my clients.

Microsoft has acknowledged that the built-in phishing filter can slow down IE7 in some circumstances. It’s unclear how big a problem that describes, but it gives you something to try if you feel things have slowed down.

When you travel to a web page, the phishing filter sends each URL to a Microsoft server to check out its bonafides before allowing IE7 to display the page. The slowdown reportedly occurs when a page is made up of multiple components, each of which has its own URL to be checked. That presumably generates a lot of traffic clogging your connection, but interestingly it also apparently maxes out your processor – Microsoft’s tech document calmly notes that “CPU usage may be very high” when the phishing filter is working.

Microsoft’s workaround is simple: turn off the phishing filter and see if things speed up. (It’s listed separately on the menu under “Tools.”)

Microsoft also released a patch specifically addressed at that problem. It’s not included in the automatic update system so it has to be installed separately. I don’t have any experience with it yet so I don’t know whether it will have any profound effect but it might be worth a try. (From the list, choose “Windows XP with Service Pack 2, x86-based versions.”) Here’s an article about the update.